JK

配置工具简介

［发布说明］

发布名称： BYNetWinConfig V3.07 ------------------ 配置工具软件发布包
内容包括：
BYNetWinConfig.exe ----------- 配置工具可执行文件
BYNetWinConfig_CN.chm ----------- 配置工具中文帮助文件
BYNetWinConfig_EN.chm ----------- 配置工具英文帮助文件

［主要指标］

支持系统：Windows 2000、Windows XP、Windows server 2003、Windows Vista、Windows 7操作系统。
支持设备：网络接口模块：JK-E01(FV1.05及以上版本)、JK-W01(FV1.000及以上版本)、JK-W03(FV1.000及以上版本)、JK-E02(FV2.000及以上版本)、JK-E04、JK-E05。
JK-E04支持设备：BTP-98NP(FV1.000及以上版本)
BTP-58TS(FV1.001及以上版本)
BTP-L580II(FV1.000及以上版本)

注意：
1、为了更好的使用JK-E02、JK-W03接口设备，在Windows 2000、Windows XP、Windows server 2003系统下需要安装IPX/SPX协议。
2、查询状态、打印自检页功能只针对POS类打印机适用。

［版本记录］

版本：V3.07
发布时间：2013年5月
版本信息：添加JK-W03的支持。

版本：V3.06
发布时间：2012年6月
版本信息：添加JK-E05的支持。

版本：V3.05
发布时间：2010年6月
版本信息：UDP广播搜索时，过滤MAC地址的重复性，列表显示一个MAC对象设备信息。

版本：V3.04
发布时间：2009年11月
版本信息：1、添加JK-E04接口打印机UDP广播搜索配置功能。
2、修改网络参数网关地址限制条件。
3、修改JK-E02修改打印端口及密码修改下发指令顺序。

版本：V3.03
发布时间：2009年5月
版本信息：添加WPANONE、WPA2-PSK无线安全加密协议，添加UDP广播搜索配置协议。

版本：V3.01
发布时间：2009年3月
版本信息：添加JK-E02接口DHCP设置超时时间；添加状态查询功能，修改PASSWORD提示信息。

版本：V3.0
发布时间：2008年9月
版本信息：增加JK-E02的IPX协议搜索配置功能支持，增加中英文转换功能。

版本：V2.0
发布时间：2006年5月
版本信息：首次发布，兼容JK-E01、JK-W01两大接口模块功能。


JK

安装与卸载

配置工具软件不提供安装程序，把BYNetWinConfig.exe文件复制到用户主机目录，完成安装工作。

删除BYNetWinConfig.exe文件，完成配置工具软件卸载工作。

运行

双击BYNetWinConfig.exe文件，运行配置工具软件，弹出配置工具主界面：

功能

配置工具软件主要通过TCP、UDP、UDP广播、IPX、TFTP网络协议与网络打印设备实现通讯服务；实现的主要功能包括：

中英文语言转换功能；

搜索配置协议设置功能；

搜索打印机功能；

设置无线参数功能；

设置网络参数功能；

接口固件升级功能；

查询打印机状态功能；

打印自检页功能；

复位功能。


新建网页 1

中英文语言转换功能

软件支持简体中文、英文，默认英文。

搜索打印机功能

搜索功能：点击“搜索打印机”按钮，根据选择的搜索配置协议进行搜索，完成搜索功能：

搜索不到打印设备，会有相应信息对话框提示。正常连接搜索不到打印机，可以参考“附录/常见问题及解答/问题1”

打印自检页功能

选择列表框中信息栏，点击“打印自检页”按钮，完成设备打印自检页功能。

备注：
1、此功能只支持POS类打印机。
2、打印自检页失败的原因有：1）、打印机与主机间TCP协议通讯交换机不支持，打印机与主机网络参数不在同一网段或交换机限制通讯；2）、打印机掉线或关电。


搜索配置协议设置

搜索配置协议设置功能

点击“搜索配置协议设置”按钮，弹出选择搜索配置协议窗口：

UDP协议搜索配置：JK-E01、JK-E02、JK-W01、JK-W03接口设备网络参数必须与用户电脑主机在同一网段内，JK-W01、JK-W03无线网络必须连接正常；IP地址不能存在冲突。

UDP广播协议搜索配置：JK-E02（固件版本：FV2.010）、JK-E04、JK-E05、JK-W03接口设备，可以实现跨网段搜索、配置；可以搜索到多个IP地址相同的对象，对各自进行参数配置。

IPX/SPX协议搜索配置：JK-E02、JK-W03接口设备网络参数可以与用户电脑不在同一网段，但用户主机必须安装IPX/SPX协议支持，并且属性设置帧类型为“Ethernet 802.3”，网络号设置为“00000000”或“00000001”。

如果IPX协议设置后还搜索不到JK-E02、JK-W03接口打印机，请按照前提条件2）设置主机与JK-E02、JK-W03打印机网络参数在同一网段内，再进行搜索。

UDP与IPX/SPX协议搜索配置：先通过UDP协议搜索，后通过IPX/SPX协议搜索，不能存在IP地址冲突。

备注：不同接口模块、不同协议搜索到的打印机支持的配置功能不尽相同，参考列表描述：

 | JK-E01 | JK-W01 | JK-E02 | JK-E04 | JK-E05 | JK-W03
UDP协议 | 1、设置网络参数（DHCP、手动设置IP参数、恢复默认设置） 2、接口固件升级 3、查询打印机状态 4、打印自检页 | 1、设置无线参数 2、设置网络参数（DHCP、手动设置IP参数、恢复默认设置） 3、接口固件升级 4、查询打印机状态 5、打印自检页 6、复位 | 1、密码验证 2、设置网络参数（所有设置） 3、接口固件升级 4、查询打印机状态 5、打印自检页 6、复位 | - | - | 1、密码验证 2、设置网络参数（所有设置） 3、接口固件升级 4、查询打印机状态 5、打印自检页 6、复位
UDP广播协议 | - | - | 1、密码验证 2、设置网络参数（所有设置） 3、查询打印机状态 4、打印自检页 5、复位 | 1、设置网络参数（手动设置IP参数、修改设置打印端口号、恢复默认设置） 2、查询打印机状态 3、打印自检页 4、复位 | 1、设置网络参数（DHCP，手动设置IP参数、修改设置打印端口号、恢复默认设置） 2、查询打印机状态 3、打印自检页 4、复位 | 1、密码验证 2、设置网络参数（所有设置） 3、查询打印机状态 4、打印自检页 5、复位
IPX协议 | - | - | 1、密码验证 2、设置网络参数（所有设置） 3、查询打印机状态 4、打印自检页 5、复位 |  | - | 1、密码验证 2、设置网络参数（所有设置） 3、查询打印机状态 4、打印自检页 5、复位


新建网页 1

设置无线参数功能

选择列表框中搜索到的打印机对象，如果是JK-W01、JK-W03（无线）接口打印机，点击“设置无线参数”按钮，弹出无线参数配置界面：

通过无线参数配置界面，可以实现对区域的选择修改、基本设置参数配置修改、安全模式的配置；

无线基本参数配置包括：
通讯模式配置：基站式、点对点式，默认为点对点式。
SSID设置：无线服务设置ID号，默认为：defaultSSID。
频道设置：当选择基站式时，频道自动获取； 点对点式时，频道设置范围与选择国家相关。

安全模式设置包括：
加密方法：WEP、WPANONE、WPA-PSK、WPA2-PSK。
Wep模式：Open system、Shared Key。
Wpa模式：AES、TKIP。
Wep大小：64bit（40bit）、128bit（104bit）。
Wep格式：ASCII、Hex。
Wep/Wpa数据：根据以上设置，输入相应格式、长度的Wep/Wpa加密数据。

配置修改完成，点击“确定”按钮，完成无线参数配置修改。

备注：对于JK-W01和JK-W03的无线参数配置修改，配置修改完成后需要点击“复位”按钮，来完成远程复位功能，使配置修改生效。


新建网页 1

设置网络参数功能

选择列表框中搜索到的打印机对象，点击“设置网络参数”按钮。

1）、如果是JK-E02、JK-W03接口打印机，会先弹出密码验证窗口：

默认密码为空，可以直接点击“确定”进入网络参数配置窗口；如果设置了密码，需要输入设置密码，验证正确后直接进入网络参数配置窗口，验证失败会提示“密码验证失败”。

2）、如果是JK-E01、JK-W01、JK-E04、JK-E05接口打印机，点击“设置网络参数”按钮直接弹出网络参数配置窗口：

通过网络参数配置界面，可以实现对IP地址、子网掩码、网关地址等参数的配置修改，配置方式有两种：一是自动获得IP地址(JK-E02、JK-E05、JK-W03接口需要设置DHCP超时时间 ，JK-E04不支持DHCP方式)；二是手动设置方式。
通过网络参数配置界面，可以实现恢复默认设置，所有参数恢复到出厂设置值。
通过网络参数配置界面，可以设置JK-E02、JK-W03接口特有的参数配置，包括创建新密码(最大长度为10)。
通过网络参数配置界面，可以设置JK-E02、JK-E04、JK-E05和JK-W03接口特有的参数配置，包括配置打印端口（1-65534，其中9000、4000、3100、3000、515、80、69、21端口已被占用，不可设置）。
通过网络参数配置界面，可以设置JK-E05接口模块开启、关闭未连接网线报警功能。

修改配置网络参数完成，点击“确定”按钮，完成网络参数配置修改。

备注：

1）、IP地址与网关地址非空设置存在特殊性：

 | ip1 | ip2 | ip3 | ip4
范围 | 1 ≤ ip1 ≤ 223 | 0 ≤ ip2 ≤ 255 | 0 ≤ ip3 ≤ 255 | 0 ≤ ip4 ≤ 255

IP地址与网关地址不能设置为子网内首地址和广播地址，IP地址与网关地址必须在同一子网内。IP地址不能设置为“127.0.0.1”。

2）、子网掩码配置存在特殊性：

 | sub1 | sub2 | sub3 | sub4
范围 | 128/192/224/240/248/252/254/255 | 0/128/192/224/240/248/252/254/255 | 0/128/192/224/240/248/252/254/255 | 0/128/192/224/240/248/252/254

四个段不能出现断层，必须是连续的，四个段数据依次转换为二进制数据，只能允许一次高低交替，中间不能出现高低位交替，如：

正确：sub1 = 255, sub2 = 254, sub3 = 0, sub4 = 0；二进制体现为 11111111 11111110 00000000 00000000。

错误：sub1 = 255, sub2 = 254, sub3 = 128, sub4 = 0；二进制体现为 11111111 11111110 10000000 00000000。

3）、对于JK-W01、JK-E02、JK-W03的配置修改，配置修改完成后需要点击“复位”按钮，来完成远程复位功能，使配置修改生效。
4）、如果是对出厂产品参数修改设置，请参考“附录/常见问题及解答/问题4”
5）、对于JK-W01设置，点对点模式下不能采用自动获得IP地址方式。
6）、DHCP超时时间只针对JK-E02、JK-W03接口有效，JK-E01、JK-W01不支持此功能。
7）、JK-E04接口不支持DHCP方式获取IP参数。


新建网页 1

接口固件升级功能

选择列表框中搜索到的打印机对象，点击“接口固件升级”按钮，弹出网络接口固件升级窗口：

点击“打开文件”按钮，选择打开要升级的固件程序文件，然后点击“升级”按钮，信息框显示升级进度，完成固件升级，成功提示升级完毕信息，失败会提示具体失败信息。

注意：在升级过程中，不允许对网络设备进行其他操作。

备注：对于JK-W01、JK-E02、JK-W03的固件升级完成后需要点击“复位”按钮，来完成远程复位功能，使升级生效。


查询设备状态功能

查询打印机状态功能

选择列表框中搜索到的打印机对象，点击“查询打印机状态”按钮，弹出查询打印机状态窗口：

通过此界面，点击“查询状态”按钮，查询选择的打印机状态，状态列表动态显示各状态，状态正常显示绿色，状态错误显示红色，默认显示灰色。

正常状态图：

错误状态图：

备注：
1、此界面显示POS类打印机状态列表。不支持其它打印机查询状态。
2、查询状态为“打印机离线”，存在的原因有：1）、打印机与主机间TCP协议通讯交换机不支持，打印机与主机网络参数不在同一网段或交换机限制通讯；2）、打印机掉线或关电。


新建网页 1

复位功能

选择列表框中信息栏，点击“复位”按钮，弹出复位功能确认窗口：

根据信息提示，选择是否完成设备复位功能，选择“确定”，完成复位，使配置的参数修改生效。

备注：打印机复位成功后存在走纸动作。


新建网页 1

［问题1］网络接口打印机连接正常，为什么配置工具无法搜索到此打印机？

［解答1］引起搜索不到正常连接打印机的原因如下几个方面：

1）、如果采用UDP协议搜索，首先，检查防火墙是否关闭，防火墙可以屏蔽进程访问网络，请关闭防火墙；其次，检查打印机网络参数与用户PC机网络参数是否在同一网段，请配置用户PC机网络参数与打印机在同一网段。

2）、如果采用IPX/SPX协议搜索，首先，检查用户PC机是否安装了IPX/SPX协议，安装方法如下：

以下为Windows XP系统下安装IPX协议步骤：

打开“网上邻居”属性，选择“本地连接”，点击右键属性，打开属性对话框：

点击“安装”按钮，弹出以下对话框：

选择“协议”，点击“添加”按钮，弹出以下对话框：

选择“NWLink IPX/SPX/NetBIOS Compatible Transport Protocol”，点击“确定”按钮完成IPX协议安装。

其次，检查IPX/SPX协议参数配置是否正确，检查方式如下：

安装完成IPX/SPX协议后，选择IPX/SPX协议项点击“属性”按键，打开IPX/SPX属性窗口，设置帧类型为“Ethernet 802.3”，网络号设置为“00000000”或“00000001”，如图所示：

3）、如果采用UDP广播协议搜索打印机，请检查网络接口板型号是否为JK-E02，同时接口板固件版本号是否为FV2.010及以上版本。

4）、如果以上问题都不存在，还是搜索不到网络接口打印机，请检查用户PC机是否安装有两个或两个以上的网卡，此时请网络管理员协助设置网卡的优先级或停止使用当前网卡以外的网卡，再使用配置工具搜索 。
搜索完成后，多网卡还会影响配置功能，如密码验证、配置网络参数、配置无线参数、复位等功能。

［问题2］在Windows Vista系统下，为什么无法安装IPX/SPX协议？

［解答2］因为Windows Vista系统不支持IPX/SPX协议。

［问题3］在配置JK-E02参数时，设置了新密码，但没有进行复位操作，再重新进入配置界面时，输入原密码提示验证失败？

［解答3］因为JK-E02参数配置时，接口板系统对密码的处理属于实时处理，立马生效，此时可以输入新密码进入配置界面。

［问题4］如何配置出厂设置的接口板参数？

［解答4］如果用户使用的是JK-E01、JK-W01接口打印机，进行出厂参数配置时，需要单台连接进行搜索配置，修改不同的IP地址等参数，确保正常使用不存在IP地址冲突。
如果用户使用的是JK-E02接口打印机，进行出厂参数配置时，可以通过IPX/SPX协议搜索多台设备，然后配置不同的IP地址等参数，确保正常使用不存在IP地址冲突 ；
也可以采用UDP广播方式进行多台出厂设置参数进行分别配置，此方式只支持JK-E02（FV2.010及以上版本）。

［问题5］用户PC机Windows系统无法配置无线连接，如何处理？

［解答5］点击“网上邻居”右键属性，选择“无线网络连接”，点击属性确认问题所在，情况有两种：

一种情况是属性界面没有“无线网络配置”页面，如图所示：

说明“Wireless Zero Configuration”服务没有启动，启动步骤如下：

点击“我的电脑”右键菜单，选择“管理”打开“计算机管理”界面，选择“服务和应用程序”中“服务”，找到选择“Wireless Zero Configuration”服务，启动此服务即可，如图所示：

启动后重新打开“无线网络连接”右键属性界面，进入“无线网络配置”页面，选中“用Windows配置我的无线网络配置”，如图所示：

点击“确定”就可以实现Windows系统配置无线连接了，如图所示：

第二种情况是有“无线网络配置”页面，只是没有选中“用Windows配置我的无线网络配置”，此时选中此项，点击“确定”即可进行Windows系统配置无线连接。

［问题6］在搜索到JK-E02、JK-E04、JK-E05接口打印机设备时，进行查询状态、打印自检页功能操作，提示离线或打印失败。

［解答6］因为JK-E02、JK-E04、JK-E05接口打印机支持跨网段搜索，而查询状态、打印自检页功能支持TCP协议通讯，是面向连接的通讯方式，如果打印机与主机网络参数不在同一网段，或网络交换机限制了此网段间的通讯，都会出现标题现象。解决方法：
1、设置打印机与主机网络参数在同一网段内；
2、有网络管理员设置网络交换机参数支持此网段间的通讯。